New York Water furnace

Discussion in 'Maintenance and Troubleshooting' started by Ron t, Sep 9, 2020.

  1. Ron t

    Ron t New Member

    Hi all... I’m new to this forum. I have a few questions, hopefully some Techs can answer.
    I have a Water Furnace Heat pump, model Premier 2 (AT019) 1.5 ton, 21 yrs old. Installation is in a condo apt with water tower and boiler.
    I’m trying to ascertain the the normal operating Water temp and psi in and out of the unit.

    Currently during a/c mode the water temp entering the unit is 80 degrees and exiting the unit at 102 degrees. Is this to high? I’m wondering if the heat exchanger needs flushing or some other service.

    Also, water pressure entering is 60 psi ( whether the unit is running or not) Which I believe is normal. But my concern is that the psi water pressure exiting the unit is at 40 psi when the unit is not running, and gradually will build up to 60 psi only after the unit is running for about 5 minutes, and then will hold at 60 psi until the unit shuts off and then psi returns gradually again to 40 psi. Does this sound normal?

    Thanks for any advise you can offer.
    Ron
     
  2. SShaw

    SShaw Member

    The Premier manual is attached. See page 37 for the specs. Your water-side delta-temp is within spec for 1.5 GPM/ton flow. For a two ton unit that would be 3.0 GPM. The water pressure drop across the heat exchanger is only 1.1 PSI at 3.0 GPM, so you might not be able to measure the difference.

    Why are you asking these questions? Is the system not performing normally?

    What's the air-side delta-T? It should be 15-20 degrees.
     

    Attached Files:

  3. Ron t

    Ron t New Member

    Thank you, SShaw.
    The air side is within the range you outline. My concern is that the out water temp on my unit is much hotter than other units in the building. Other units ( although of different manufacturers) show approximate 10 degree Td, and Mine is 22 degrees. Twice this summer on very hot days the unit shut down on high pressure fault. I reset the unit and it resumes normal operation.
     
  4. SShaw

    SShaw Member

    The water delta-t does sound high to me too, especially compared to my WF 7 Series. However, it's within the published specs for that model.

    The high pressure fault could be from low water flow, low air flow, or from a faulty pressure sensor (bad connection, loose wire, etc.) The delta-ts do not indicate a problem with the water or air flow, so maybe it's a problem with the pressure sensor.

    Is the air filter clean and a low restriction model (MERV-11 or lower rating)? Are all the supply and return vents clear?

    Maybe someone with experience with the Premier units will chime in.
     
  5. Ron t

    Ron t New Member

    All is well on the air side. Clean merv 8 filter, clean vents, etc. I keep thinking the issue could be a restricted Heat exchanger. Hopefully someone with premier experience will offer thoughts. Thanks again for your insight.
     

Share This Page