Ohio Thermostat issues

Discussion in 'Maintenance and Troubleshooting' started by Smackre, Sep 27, 2016.

  1. Smackre

    Smackre New Member

    I have a Tetco geothermal heat pump and I am looking for advise about my thermostat issue. Right now I have a Honeywell programmable thermostat and for some reason it will not call up heat. It worked all summer calling up air but when I turn on heat all that turns on is the fan. I can take pictures of everything later when I get home. I will take pictures of the termostat connection and the connection on the geo unit. Please advise if you want pictures of anything else. This is a 2 stage unit. Someone told me to buy a Honeywell 8300.

    Is this the one they are meaning?
  2. mrrxtech

    mrrxtech Member

    Has this thermostat ever been used in the heating mode, or is your system new, or new to you, and has never worked in the heating mode.

    If the Unit has been around for a while and has heated the home, I would check the thermostat wire connections at both ends to see if the Reversing Valve wire has come lose.

    Another problem could be similar to what one of my Units has for now, in the Heating Mode if you call for more than 2 degrees heating, the 2nd stage is called for but is currently disconnected at the Y2 connection on the thermostat, so the thermostat goes into the Auxiliary Heat mode, causing the fan to run but no compressor operation. I put the 2 stage unit in the first stage only mode for the summer due to some issues the Unit was having in the 2nd stage mode. The house only needs 2 Tons of cooling but could use the 3rd Ton for Heating in the Winter.

    If you are going to buy the Honeywell Thermostat, try this one due to the better price.
  3. mrrxtech

    mrrxtech Member

    The Honeywell thermostat above has the Y2 connection needed for 2 stage heating and cooling. This operates the electromagnet that moves a hoop or ring up in the 2nd stage to cover the bypass orifice, adding the 2nd stage tonnage to your compressor.
  4. Smackre

    Smackre New Member

    This issue has been resolved. Thanks for the help Mrrxtech.
  5. mrrxtech

    mrrxtech Member

    Your welcome Smackre.

Share This Page