I am doing a DIY system install

Discussion in 'General Discussions' started by SolarPower, Nov 25, 2018.

  1. SolarPower

    SolarPower Member

    My Geothermal system did better this last winter now that the loop is older. My loop temps stayed much better all winter. I did not have to use second stage as much.

    I am not sure how the summer loop temps will do this summer. Even when my summer loop temps went higher than I thought they would the system still worked well all summer.
     
  2. RenewPower

    RenewPower New Member

    I've had trouble finding a solar contractor that didn't want more than double the DIY cost. Its almost like they just calculate parts + labor and add the current federal rebate the "cost". My biggest design challenge is we're attempting to place the solar array in a field 1000 feet from the meter - wife doesn't like the 'look' of panels :rolleyes: - all while trying to engineer the vdrop to acceptable levels. What was your home run cable you used? #8? What was your Vdrop on the home run? I think I need to keep it below 1% if I'm reading the enphase notes correctly to maintain hardware / home run vdrop totals below 3%. I have a handful of technical questions if you're willing to help. Just subscribed to ecorenovator - since thats probably a more appropriate place for my solar questions, but its not letting me PM or post... :mad:
     
  3. SolarPower

    SolarPower Member

    The system has been running a couple years now. It is still working good the loop temp is 47.1 degrees 1/11/21.

    The loop did not get as hot over the summer. The loop has seemed to improve over time. Maybe dirt settled in around the loops.

    It just works we are happy with the comfort level it keeps the house. It is nice having it provide preheated hot water.

    The only thing is not a convenient is the to change filters I have to go in the crawl space. But the filters do not get changes as often so it is not that bad.
     
  4. SolarPower

    SolarPower Member

    My system was losing pressure. I got a freeze alert because of pressure loss and no flow. I pressurized the loop then I turned on the AC to thaw it out. This all worked well. I have the pipes all insulated very well so it was hard to see the drip.

    I had 1” push fit fittings from the manifold to the Geo unit. They were in a crawl space. They did not age well. They lasted about 2 years.

    There were about six of them and they all were dripping. I replaced them all with crimp connectors. It is holding pressure good again and working great again.
     
  5. gsmith22

    gsmith22 Active Member Forum Leader

    a sharkbite or john guest type connection? what type/brand of push fit? I have no need to use that on my geo system, but had considered them for plumbing (domestic potable water) in the past and decided not to. Just wasn't sure how well the o ring seals would age. Admittedly, I have never heard of a sharkbite type connection failing so figured it was all in my head. Would be interested to hear more details.
     
  6. SolarPower

    SolarPower Member

    I am not sure of the name of the fittings they were not shark bite. They were supplied with the kit I got.

    I had never used push fittings before. I have only used crimp fillings up to this point.
    I have them in the garage I will see if there is a name on them.
     

    Attached Files:

  7. SolarPower

    SolarPower Member

    Four years later and the system is still working well.
    I did just buy a pump just to have on hand just incase.
    I would hate to be out of heat or AC and not have a pump to replace it.
     
    Deuce likes this.

Share This Page